Goals available for this plugin:

Goal Description
conga-aem:help Display help information on conga-aem-maven-plugin.
Call mvn conga-aem:help -Ddetail=true -Dgoal=<goal-name> to display parameter details.
conga-aem:package-install Installs all AEM content packages to AEM which are referenced in a model.yaml generated by CONGA for a node.

System Requirements

The following specifies the minimum requirements to run this Maven plugin:

Maven 3.0.5
JDK 1.8
Memory No minimum requirement.
Disk Space No minimum requirement.

Usage

You should specify the version in your project's plugin configuration:

<project>
  ...
  <build>
    <!-- To define the plugin version in your parent POM -->
    <pluginManagement>
      <plugins>
        <plugin>
          <groupId>io.wcm.devops.conga.plugins</groupId>
          <artifactId>conga-aem-maven-plugin</artifactId>
          <version>1.9.3-SNAPSHOT</version>
        </plugin>
        ...
      </plugins>
    </pluginManagement>
    <!-- To use the plugin goals in your POM or parent POM -->
    <plugins>
      <plugin>
        <groupId>io.wcm.devops.conga.plugins</groupId>
        <artifactId>conga-aem-maven-plugin</artifactId>
        <version>1.9.3-SNAPSHOT</version>
      </plugin>
      ...
    </plugins>
  </build>
  ...
</project>

For more information, see "Guide to Configuring Plug-ins"

Back to top

Version: 1.9.3-SNAPSHOT. Last Published: 2019-10-21.